ComX Computers - since 2002 • home Fri 9 Oct, 2026View enquiry cart
Computers, laptops and PC hardware in South Africa.Computers
Laptops
Laptops, computers and computer hardware South Africa Computers, laptops and other PC hardware in South Africa.
Computers South AfricaLaptops, Notebooks and PDA South AfricaDigital camerasComputer hardware Tablets South AfricaSoftware - software titles South AfricaPrinters South Africa SpeakersGaming Brands
PC
My account  |  How to buy  |  Specials
computer salespc salescomputerscomputerscomputers
computers
 
computers
computers

TD-W9960 TP-Link TD-W9960 4 port 300 Mbps Wireless VDSL / ADSL Router

computers

TD-W9960

computers
TD-W9960
R 660.00
inc. VAT
Out of Stock





TP-Link TD-W9960 4 port 300 Mbps Wireless VDSL / ADSL Router
Images are for illustrative purposes and actual product may differ.
TD-W9960 image 1TD-W9960 image 2TD-W9960 image 3TD-W9960 image 4

   

TD-W9960

Network Routers (wired broadband routers)

TP-link


TD-W9960 information and overview
TP-Link TD-W9960 4 port 300 Mbps Wireless VDSL / ADSL Router, 3x 10/100 Mbps RJ45 LAN Ports, 1x 10/100 Mbps RJ45 LAN/WAN Port, 1x RJ11 Port, Omni Directional fixed antenna Type, 2x 5dBi antenna gain
Great value! This product is available for only R 660.



Specifications & more information about TD-W9960, Network Routers (wired broadband routers) manufactured by TP-link
Specifications & downloads View specification Printable PDF
Product information notice: Some specifications may describe a broader product range and may not apply to this exact model. Use the product summary above as the primary model reference. Bundled software may be trial software and can require a separate licence.
Overview:

TD-W9960 - 300Mbps Wireless N VDSL/ADSL Modem Router
  • Versatile Connectivity - With DSL and LAN/WAN ports, TD-W9960 is fully compatible with the VDSL2/ADSL2+/ADSL2/ADSL standards and also works with fiber/cable access.
  • Boosted Speeds - Superfast VDSL broadband speeds of up to 100Mbps together with 300Mbps Wi-Fi.
  • Maximized Range - Powerful external antennas provide far-reaching wireless coverage in every direction.
  • Effortless Management - Set up in minutes with the powerful Tether app or intuitive web interface and manage the network from anywhere.
Features:

The Best VDSL for Every Home
300Mbps Wireless N VDSL/ADSL Modem Router

Superfast VDSL Modem Router
VDSL2 technology delivers VDSL broadband speeds of up to 100Mbps simultaneously in both the upstream and downstream directions. The integrated DSL port supports all standard DSL connections* for compatibility with most ISPs.

*The TD-W9960 is compatible with VDSL2, ADSL2+, ADSL2 and ADSL.

Wi-Fi Speed Up to 300Mbps
With 300Mbps wireless speeds on the 2.4GHz band and 4 megabit LAN ports, the TD-W9960 is perfect for streaming in HD, online gaming and other bandwidth-intensive applications.

Easy Setup and Management
Set up the TD-W9960 in minutes thanks to its intuitive web interface and the powerful Tether app. Manage network settings, including Parental Controls and Access Control, from any Android or iOS device. Control your home network whenever and wherever you are.

Powerful Antennas
Two external 5dBi high-gain antennas beam signal to every corner of your home, creating a strong, stable Wi-Fi network.

6kV Lightning Protection
Lightning protection shields TD-W9960 from electrical damage caused by thunderstorms, so even in bad weather, you can enjoy internet with peace of mind.

Secure Surfing
Parental Controls limit the online time and access of specified devices. Guest Network creates a separate Wi-Fi network for visitors, keeping your main network secure.

Specifications:

© 2026 Respective owners and brand holders. This table has been carefully researched and generated by ComXpert International CC (//www.comx.co.za), however, errors and omissions may occur. Only references to South Africa apply. All products are sourced in South Africa from the official suppliers and the warranty is that of the local supplier. E&OE. This table and our site's content may be used on condition that this notice and link remains intact and unaltered.
Specifications and features
Product Code TD-W9960spacer
HARDWARE FEATURES
Interface3 10/100Mbps RJ45 LAN Ports
1 10/100Mbps RJ45 LAN/WAN Port
1 RJ11 Port
ButtonWPS Button
RESET Button
Power ON/OFF Button
External Power Supply9VDC/0.6A
IEEE StandardsIEEE 802.3, 802.3u
VDSL2 StandardsITU-T G.993.2
ITU-T G.993.5 (G.vector)
ITU-T G.998.4 (G.INP)
Dimensions ( W x D x H )181.6 x 129.7 x 36.2mm
Antenna TypeOmni directional, Fixed
Antenna Gain2 x 5dBi
WIRELESS FEATURES
Wireless StandardsIEEE 802.11b, 802.11g, 802.11n
Frequency2.400-2.4835GHz
Transmit Power<20dBm(EIRP)
Wireless Security64/128-bit WEP, WPA/WPA2, WPA-PSK/WPA-PSK2
encryptions, Wireless MAC Filtering
SOFTWARE FEATURES
Quality of ServiceWMM, Bandwidth Control (IP QoS)
SecurityNAT Firewall, SPI Firewall, DoS Protection, IP & MAC Binding, Service Filtering, Access Control, Parental Controls
Operating ModesVDSL/ADSL Modem Router, Wireless Router
ManagementWeb Based Configuration (HTTP), Remote management, CWMP(TR-069), Web Based Firmware Upgrade, Diagnostic Tools
VPN Pass-ThroughIPSec VPN
ProtocolsSupports IPv4 and IPv6
ATM/PPP ProtocolsPPPoE (RFC2516)
PPPoA (RFC 2364)
MERIPoE (RFC 1483 Routed)
IPoA (RFC1577/2225)
Bridge (RFC1483 Bridge)
Advanced FeaturesParental Controls, Network Address Translation(NAT), Port Mapping(Grouping), Static Routing, RIP v1/v2(optional), DNS Relay, DDNS, IGMP V1/V2/V3
APPTether App
NATVirtual Server, Port Triggering, DMZ, ALG, UPnP
OTHERS
CertificationCE, RoHS
Package ContentsTD-W9960
External DSL Splitter
RJ-11 DSL Cable
RJ-45 Ethernet Cable
Quick Installation Guide
Power Adapter
System RequirementsMicrosoft Windows 98SE, NT, 2000, XP, Vista or Windows 7, 8, 8.1, 10
Mac OS, NetWare, UNIX or Linux
Internet Explorer 11, Firefox 12.0, Chrome 20.0, Safari 4.0, or other
Java-enabled browser
Subscription with an internet service provider (for internet access)
EnvironmentOperating Temperature: 0°C~40°C(32°F~104°F)
Storage Temperature: -40°C~70°C(-40°F~158°F)
Operating Humidity: 10%~90% non-condensing
Storage Humidity: 5%~90% non-condensing


Similar Network Routers (wired broadband routers)

WebAfrica Internet



The best price and guaranteed service and backup from official computer suppliers in South Africa for the TD-W9960 TP-Link TD-W9960 4 port 300 Mbps Wireless VDSL / ADSL Router.
Available from this online computer store delivering door-to-door in Johannesburg, Cape Town, Port Elizabeth, Pretoria, Pietermaritzburg, Polokwane, Durban and all over South Africa.

Find related TD-W9960 TP-Link TD-W9960 4 port 300 Mbps Wireless VDSL / ADSL Router products in our Network Routers (wired broadband routers) Category for even more options. Read reviews and find out about TD-W9960 TP-Link TD-W9960 4 port 300 Mbps Wireless VDSL / ADSL Router. Discounts, specials and cheap prices only at ComX Computers.




 
TD-W9960 laptops South AfricaTD-W9960 Notebooks South AfricacomputersTD-W9960 notebook sales in South Africa
Home | Contact Us | Privacy Policy | Shop by Brand | Shop by Category
CGSO
ComX Computers is a South African online store since 2002. All transactions are subject to our terms of sale.