ComX Computers - since 2002 • home Wed 28 Oct, 2026View enquiry cart
Computers, laptops and PC hardware in South Africa.Computers
Laptops
Laptops, computers and computer hardware South Africa Computers, laptops and other PC hardware in South Africa.
Computers South AfricaLaptops, Notebooks and PDA South AfricaDigital camerasComputer hardware Tablets South AfricaSoftware - software titles South AfricaPrinters South Africa SpeakersGaming Brands
PC
My account  |  How to buy  |  Specials
computer salespc salescomputerscomputerscomputers
computers
 
computers
computers

ARCHER-VR300 TP-Link Archer VR300 AC1200 Wireless VDSL/ADSL Modem Router

computers
R 722.00
inc. VAT
In Stock




TP-Link Archer VR300 AC1200 Wireless VDSL/ADSL Modem Router
Images are for illustrative purposes and actual product may differ.

   

ARCHER-VR300

Wireless Routers (ADSL / VDSL)

TP-link


ARCHER-VR300 information and overview
TP-Link Archer VR300 AC1200 Wireless VDSL/ADSL Modem Router
Great value! This product is available for only R 722.



Specifications & more information about ARCHER-VR300, Wireless Routers (ADSL / VDSL) manufactured by TP-link
Specifications & downloads View specification Printable PDF
Product information notice: Some specifications may describe a broader product range and may not apply to this exact model. Use the product summary above as the primary model reference. Bundled software may be trial software and can require a separate licence.

Features:

  • Parental Controls: manage responsible internet access for your children
  • Guest Network|: provides separate access for guests while securing the home network
  • Firewall Security: supports DoS, SPI Firewall, IP Addressing/Domain Filter, IP/MAC Address Binding
  • Quality of Service: prioritizes network traffic by device or application
  • IPTV IGMP Proxy/Snooping: supports Bridge and Tag VLAN for smooth IPTV application
  • IPv6: compatible with IPv6 (Internet Protocol version 6)
  • Multilingual Interface: provides hassle-free configuration in six languages (EN/DE/IT/TR/RU/PO)

Upgrade AC Wi-Fi to Enjoy Wireless Entertainment
As a powerful DSL modem router, the Archer VR300 makes full use of its Wi-Fi abilities by providing combined dual band Wi-Fi speeds of up to 1200Mbps. 300Mbps on 2.4GHz is perfect for everyday surfing and emailing, while 867Mbps on 5GHz provides lag-free HD streaming and gaming.

Superfast VDSL Broadband
The latest VDSL2 technology allows the Archer VR300 to deliver impressive VDSL broadband speeds of up to 100Mbps, which is almost five times faster than ADSL2+. The Archer VR300 serves as a DSL modem and wireless router, combining two devices in one. The integrated DSL port supports all standard DSL connections, including VDSL2, ADSL2+, ADSL2, and ADSL.

External Antennas Greatly Expand Wireless Coverage
Four external antennas with advanced connection technology allow you to maintain impressive speeds, even over greater distances. This means that you can enjoy incredible wireless coverage and reliability in any part of your large home or office.

Easy Setup and Management
Set up the Archer VR300 in minutes thanks to its intuitive web interface and the powerful Tether app. Manage network settings, including Parental Controls and Access Control, from any Android or iOS device. Tether also provides Automatic Firmware Updates to always give your network the latest performance and security.

Remote Control
With TP-Link Tether App and DDNS, you can control your home network wherever you are.

Safe, Family-Friendly Surfing
Parental Controls manage when and how connected devices can access the internet. Guest Network keep your main network secure while creating a separate network for guests and visitors.

6kV Lightning Protection
6KV Lightning Protection provides shields against electrical damage caused by thunderstorms so that you can enjoy your life even in bad weather.

Specifications:

©2026 Respective owners and brand holders. This table has been carefully researched and generated by ComXpert International CC (//www.comx.co.za), however, errors and omissions may occur. Only references to South Africa apply. All products are sourced in South Africa from the official suppliers and the warranty is that of the local supplier. E&OE. This table and our site's content may be used on condition that this notice and link remains intact and unaltered.
Specifications
Product Code NET-ARCHER-VR300
HARDWARE FEATURES
Interface 3 10/100 RJ45 LAN Ports
1 10/100 RJ45 LAN/WAN Port
1 RJ11 Port
Button WPS Button
Power On/Off Button
Reset Button
Power Supply 12V/1A
VDSL2 Standards ITU G.993.2, Up to 17a pro¬le (POTS)
ITU-T G.993.5 (G.vector)
ITU-T G.998.4 (G.INP)
ADSL Standards Full-rate ANSI T1.413 Issue 2,
ITU-T G.992.1(G.DMT)
ITU-T G.992.2(G.Lite)
ITU-T G.994.1 (G.hs)
ITU-T G.995.1
ADSL2 Standards ITU-T G.992.3 (G.DMT.bis)
ITU-T G.992.4 (G.lite.bis)
ADSL2+ Standards ITU-T G.992.5
Dimensions ( W x D x H ) 385*290*76mm
Antenna Type 4 fixed external antennas
WIRELESS FEATURES
Wireless Standards IEEE 802.11a/n/ac 5GHz
IEEE 802.11b/g/n 2.4GHz
Wireless Speeds 867Mbps at 5GHz
300Mbps at 2.4GHz
Transmit Power 2.4GHz <20dBm(EIRP)
5GHz <23dBm(EIRP)
Wireless Functions Access Point / Wireless Bridge, Wireless EnableDisable, SSID Broadcast EnableDisable
Wireless Security WEP, WPA/WPA2, WPA-PSK/WPA-PSK2
encryptions, QSS(WPS)
SOFTWARE FEATURES
Quality of Service ATM QoS, Bandwidth Control
Security NAT Firewall, Access Control, IP and MAC Address Binding
Operating Modes VDSL/ADSL Modem Router, Wireless Router
Management Web Based Con¬guration(HTTP), Remote management
command Line Interface, SSL for TR-069, SNMP v1/2c, Web Based Firmware
Upgrade, Diagnostic Tools
DHCP Server, Client, DHCP Client List, Address Reservation, DHCP Relay
Port Forwarding Virtual Server, Port Triggering, DMZ, ALG, UPnP
Dynamic DNS DynDns, NO-IP
VPN Pass-Through PPTP, L2TP, IPSec Passthrough
Protocols Supports IPv4 and IPv6
ATM/PPP Protocols ATM Forum UNI3.1/4.0, PPP over ATM (RFC 2364)
PPP over Ethernet (RFC2516), IPoA (RFC1577/2225), MERIPoE (RFC 1483
Routed), Bridge (RFC1483 Bridge), PVC - Up to 8 PVCs
Advanced Functions Parental Control, Network Address Translation(NAT)
Port Mapping(Grouping), Static Routing, RIP v1/v2(optional), DNS Relay
DDNS, IGMP V1/V2/V3
Guest Network 2.4GHz guest network, 5GHz guest network
OTHERS
Certification CE, RoHS, RCM
Package Contents AC1200 Wireless VDSL/ADSL Modem Router Archer VR300
External Splitter
RJ11 DSL Cable
RJ45 Ethernet Cable
Power Adapter
Quick Installation Guide
System Requirements Microsoft Windows XP/7/8/8.1/10, MAC OS, NetWare, UNIX or Linux
Internet Explorer, Firefox, Chrome, Safari or other Java-enabled browser
Subscription with an Internet Service Provider (for Internet access)
Environment Operating Temperature: 0°C~40°C (32°F ~104°F)
Storage Temperature: -40°C~70°C (-40°F ~158°F)
Operating Humidity: 10%~90% non-condensing
Storage Humidity: 5%~90% non-condensing




WebAfrica Internet



The best price and guaranteed service and backup from official computer suppliers in South Africa for the ARCHER-VR300 TP-Link Archer VR300 AC1200 Wireless VDSL/ADSL Modem Router.

Available from this online computer store delivering door-to-door in Johannesburg, Cape Town, Port Elizabeth, Pretoria, Pietermaritzburg, Polokwane, Durban and all over South Africa.

Find related ARCHER-VR300 TP-Link Archer VR300 AC1200 Wireless VDSL/ADSL Modem Router products in our Wireless Routers (ADSL / VDSL) Category for even more options. Read reviews and find out about ARCHER-VR300 TP-Link Archer VR300 AC1200 Wireless VDSL/ADSL Modem Router. Discounts, specials and cheap prices only at ComX Computers.




 
ARCHER-VR300 laptops South AfricaARCHER-VR300 Notebooks South AfricacomputersARCHER-VR300 notebook sales in South Africa
Home | Contact Us | Privacy Policy | Shop by Brand | Shop by Category
CGSO
ComX Computers is a South African online store since 2002. All transactions are subject to our terms of sale.